Issues Connecting External Hard Drives to a Retina MacBook with USB-C

Thursday, July 14, 2016

As of OS X 10.11.4 and .5, not sure which, I have issues connecting external hard drives to an Early-2015, 12-inch, retina MacBook. I suspect it has something to do with USB-C or OS X’s USB drivers. Apple’s OS X El Capitan 10.11.4 release notes reference updates to USB audio devices and Apple’s USB-C adapters.

When connecting an external hard drive to the 12-inch, retina MacBook, I use one of the following types of adapters and/or cable: Apple’s USB-C to Digital AV Multiport or VGA Multiport adapters, or a Monoprice Palette Series 3.0 USB-C to USB Micro B cable. I know the cable and two adapters are in good working order because they worked prior to OS X 10.11.4 and .5.

Additionally, everything works if I reboot the laptop and connect the external hard drives immediately after boot up. It is only after a period of time after boot up - not sure how long - the external hard drives no longer connect. Nothing shows up in Disk Utility or Console.

I have tried resetting the SMC Controller and NVRAM without any difference.

There shouldn’t be a lack-of-power issue, because the external hard drives are designed to not require an external power source.

I know the external hard drives - both 1TB Western Digital My Passwords - are in good working order because I can connect them both to an Early 2013, 15-inch, retina MacBook Pro using the standard USB 3.0 A Male to Micro B Male cable that ships with any external USB 3.0 hard drive these days without a problem.

Based on some Google research, the problem is either with USB-C or modifications Apple made to OS X’s USB drivers in OS X 10.11.4 and/or .5.

Lastly, the external hard drives connect without issue to a different 12-inch, retina MacBook running the second public beta of macOS Sierra.

Update 2016-07-20: I have installed OS X 10.11.6 on an Early-2015, 12-inch, retina MacBook and the issues above still occur.

References

External hard drives don’t show up in El Capitan: UNRESOLVED

El Capitan 10.11.4 - USB3 Drives not mounting

OS X El Capitan and its refusal to reset USB devices



comments powered by Disqus